Dashboard > iBATIS DataMapper > Home > Frequently Asked Questions > Why am I getting an exception about my provider not being found in providers.config?
Why am I getting an exception about my provider not being found in providers.config?
Added by Roberto Rabe, last edited by Roberto Rabe on May 12, 2005
Labels: 
(None)


If you get this type of exception thrown...

IBatisNet.Common.Exceptions.ConfigurationException :
    Error while configuring the Provider named "OleDb1.1".
    Cause : The provider is not in 'providers.config'.
    

...check to make sure that the provider is enabled in your providers.config file.

Sample OleDb1.1 providers.config entry

<provider
name="OleDb1.1"
description="OleDb, provider V1.0.5000.0 in framework .NET V1.1"
enabled="true"
assemblyName="System.Data, Version=1.0.5000.0, Culture=neutral, PublicKeyToken=b77a5c561934e089"
connectionClass="System.Data.OleDb.OleDbConnection"
commandClass="System.Data.OleDb.OleDbCommand"
parameterClass="System.Data.OleDb.OleDbParameter"
parameterDbTypeClass="System.Data.OleDb.OleDbType"
parameterDbTypeProperty="OleDbType"
dataAdapterClass="System.Data.OleDb.OleDbDataAdapter"
commandBuilderClass="System.Data.OleDb.OleDbCommandBuilder"
usePositionalParameters = "true"
useParameterPrefixInSql = "false"
useParameterPrefixInParameter = "false"
parameterPrefix = ""
/>


Site running on a free Atlassian Confluence Open Source Project License granted to OSS. Evaluate Confluence today.
Powered by Atlassian Confluence, the Enterprise Wiki. (Version: 2.5.5 Build:#811 Jul 25, 2007) - Bug/feature request - Contact Administrators